Degraded Performance
Incident Report for Spiff
Postmortem

There was a problem with upstream provider that caused an impact on initial load times of the application. The issue has since been resolved. Further steps to ensure that similar issues with the provider in the future will not degrade application load time are being taken.

Posted Jul 24, 2023 - 00:28 UTC

Resolved
This incident has been resolved.
Posted Jul 24, 2023 - 00:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 23, 2023 - 23:55 UTC
Investigating
We are currently investigating this issue.
Posted Jul 23, 2023 - 23:18 UTC
This incident affected: Spiff Application (app.spiff.com).