EU and US are now in a Stable state and we are monitoring reporting jobs
Posted May 06, 2025 - 23:30 UTC
Update
EU servers are now updating Reports and in a Stable state. US update is rolling out soon
Posted May 06, 2025 - 23:19 UTC
Identified
The issue has been identified and a patch is being deployed. The underlying issue is all Custom Reports, Advanced Analytics (DataCloud only), and Expense Reports in EU and US are not refreshing since yesterday (5/6 9:00pm UTC).
Posted May 06, 2025 - 22:44 UTC
Investigating
We are currently investigating an issue with data updates to Custom Reports, Advanced Analytics, and Expense Reports.